Alguns leitores do blog perceberam que tivemos um problema – Invalid query: 1045: Access denied for user ‘www-data’@’localhost’ (using password: NO)

Esse erro ocorreu após o upgrade do WordPress para a sua nova versão/release – 3.9.

O engraçado é que o meu banco não roda em localhost e muito menos utiliza o usuário www-data. Este era o usuário que rodava todo o meu conteúdo Web.

Fui obrigado a fazer o restore do backup e terei que analisar os scripts php desta nova versão do wordpress antes de realizar o upgrade.

Como sempre digo, antes de realizar qualquer upgrade no seu wordpress, tenha em mãos um backup full do seu ambiente. Vai que dá pau..

P.S.: Os meus arquivos de configuração do wordpress estão com o modo debug off, além da permissão negada para o output display de erros como este. Esta nova versão simplesmente os ignorou, e preciso entende o porque disso.